Crypto buy and sell experiencing issues
Incident Report for Step
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 15:24 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2022 - 14:06 PDT
Update
We are continuing to investigate this issue.
Posted Sep 23, 2022 - 14:05 PDT
Investigating
We are currently investigating sporadic errors around buying and selling crypto.
Posted Sep 23, 2022 - 10:09 PDT
This incident affected: Crypto Investing.