Database maintenance

Incident Report for Step

Resolved

Maintenance is complete
Posted Jun 30, 2025 - 01:30 PDT

Monitoring

We’re currently undergoing maintenance, which will take less than an hour.

Services impacted: card purchases, logging in to the app to view your accounts.
Services not impacted: incoming bank transfers, payroll/direct deposit, scheduled/recurring transfers.
Posted Jun 30, 2025 - 01:05 PDT
This incident affected: Card Purchases, Send & Receive Money, Debit Card Funding, Stock & Crypto Investing, ATM Access, Linking Bank Account, Create Account, and Referral Bonuses.