Partial outage
Incident Report for Step
Resolved
Functionality has been restored.
Posted May 09, 2022 - 16:05 PDT
Investigating
Due to an issue with multiple services, the Step app may be unable to load or some operations may fail. We are working as quickly as possible to restore full functionality.
Posted May 09, 2022 - 15:20 PDT
This incident affected: Mobile App (iOS App, Android App), Card Purchases, Send & Receive Money, Debit Card Funding, ATM Access, Linking Bank Account, Bank Transfers, Direct Deposit, Create Account, Referral Bonuses, and Support (Help Center, Live Chat).