Crypto buy/sell experiencing issues.
Incident Report for Step
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 16:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2022 - 14:56 PDT
Investigating
Attempts to buy and sell crypto may fail, we are working quickly to resolve the issue.
Posted Sep 09, 2022 - 13:49 PDT
This incident affected: Crypto Investing.